summaryrefslogtreecommitdiffstats
path: root/krebs/5pkgs/haskell/kirk.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2017-06-01 10:08:56 +0200
committermakefu <github@syntax-fehler.de>2017-06-01 10:08:56 +0200
commit772f84305d90380e0d221cf49ae3f1597d0d0510 (patch)
tree8d2241648396dc34fa96c8c68e12f832fbc7c308 /krebs/5pkgs/haskell/kirk.nix
parent90822f64e0bf247c5cca2f035077553cac5ceb79 (diff)
parent21d92086fe00c7369fde3951f92e9f73f4c05ee9 (diff)
Merge remote-tracking branch 'lass/master'
Diffstat (limited to 'krebs/5pkgs/haskell/kirk.nix')
-rw-r--r--krebs/5pkgs/haskell/kirk.nix21
1 files changed, 21 insertions, 0 deletions
diff --git a/krebs/5pkgs/haskell/kirk.nix b/krebs/5pkgs/haskell/kirk.nix
new file mode 100644
index 000000000..073e5d505
--- /dev/null
+++ b/krebs/5pkgs/haskell/kirk.nix
@@ -0,0 +1,21 @@
+{ mkDerivation, async, base, bytestring, fetchgit, network
+, optparse-applicative, stdenv, text
+}:
+mkDerivation {
+ pname = "kirk";
+ version = "1.0.1";
+ src = fetchgit {
+ url = "http://cgit.krebsco.de/kirk";
+ sha256 = "1acsmmc485c54axpy9bd0320j18hs261vl1vdxns4n04sxzqd7k0";
+ rev = "cdf3cb373af8f9b03a9487a63eb32e0226913589";
+ };
+ isLibrary = true;
+ isExecutable = true;
+ libraryHaskellDepends = [
+ base bytestring network optparse-applicative text
+ ];
+ executableHaskellDepends = [
+ async base network optparse-applicative text
+ ];
+ license = stdenv.lib.licenses.mit;
+}