summaryrefslogtreecommitdiffstats
path: root/krebs/5pkgs/hashPassword.nix
diff options
context:
space:
mode:
authorlassulus <lass@aidsballs.de>2015-07-28 22:37:28 +0200
committerlassulus <lass@aidsballs.de>2015-07-28 23:23:26 +0200
commit1bf670270c1e87900a908f7e9b949b5502158f4f (patch)
tree3a89e86813805e0d6075d3b01497d681602b45cd /krebs/5pkgs/hashPassword.nix
parentfa175ca26e533b62f3afc11709ef1689647c558c (diff)
parent06cb4d25ef40773e2cc516e50a9aeec6cbe1d0a8 (diff)
Merge remote-tracking branch 'cd/master' into newmaster2
Diffstat (limited to 'krebs/5pkgs/hashPassword.nix')
-rw-r--r--krebs/5pkgs/hashPassword.nix16
1 files changed, 16 insertions, 0 deletions
diff --git a/krebs/5pkgs/hashPassword.nix b/krebs/5pkgs/hashPassword.nix
new file mode 100644
index 000000000..a10340cc4
--- /dev/null
+++ b/krebs/5pkgs/hashPassword.nix
@@ -0,0 +1,16 @@
+{ lib, pkgs, ... }:
+
+pkgs.writeScriptBin "hashPassword" ''
+ #! /bin/sh
+ # usage: hashPassword
+ set -euf
+
+ export PATH=${lib.makeSearchPath "bin" (with pkgs; [
+ coreutils
+ mkpasswd
+ openssl
+ ])}
+
+ salt=$(openssl rand -base64 16 | tr -d '+=' | head -c 16)
+ exec mkpasswd -m sha-512 -S "$salt"
+''