summaryrefslogtreecommitdiffstats
path: root/jeschli/source.nix
diff options
context:
space:
mode:
authorlassulus <lassulus@lassul.us>2017-12-12 18:24:01 +0100
committerlassulus <lassulus@lassul.us>2017-12-12 18:24:01 +0100
commit3a235667ca84cc91974b4aef906e0f9efe900893 (patch)
tree3682258b72d9844121a6013b7953f91a220a733b /jeschli/source.nix
parent8bad968312cbf384444aabcc333b802ec141b09e (diff)
parent79d41e9f54cecd7cc0098a55a8d4b758041369e1 (diff)
Merge remote-tracking branch 'prism/staging/jeschli'
Diffstat (limited to 'jeschli/source.nix')
-rw-r--r--jeschli/source.nix22
1 files changed, 22 insertions, 0 deletions
diff --git a/jeschli/source.nix b/jeschli/source.nix
new file mode 100644
index 000000000..d5e14a8dc
--- /dev/null
+++ b/jeschli/source.nix
@@ -0,0 +1,22 @@
+with import <stockholm/lib>;
+host@{ name, secure ? false, override ? {} }: let
+ builder = if getEnv "dummy_secrets" == "true"
+ then "buildbot"
+ else "jeschli";
+ _file = <stockholm> + "/jeschli/1systems/${name}/source.nix";
+in
+ evalSource (toString _file) [
+ {
+ nixos-config.symlink = "stockholm/jeschli/1systems/${name}/config.nix";
+ nixpkgs.git = {
+ url = https://github.com/nixos/nixpkgs;
+ ref = "f9390d6";
+ };
+ secrets.file = getAttr builder {
+ buildbot = toString <stockholm/jeschli/2configs/tests/dummy-secrets>;
+ jeschli = "/home/jeschli/secrets/${name}";
+ };
+ stockholm.file = toString <stockholm>;
+ }
+ override
+ ]
[cgit] Unable to lock slot /tmp/cgit/5f000000.lock: No such file or directory (2)