summaryrefslogtreecommitdiffstats
path: root/5pkgs/uhub/default.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2021-12-04 21:24:48 +0100
committermakefu <github@syntax-fehler.de>2021-12-04 21:24:48 +0100
commitc5d9a64a5bf939ee7a1a2971dab0e749f5215ecb (patch)
tree146c3a8cb6b91a2086b16a1dae0713383c835c39 /5pkgs/uhub/default.nix
parente6be67eb5f8ef1249fef11afd7973fb473013aa5 (diff)
ma pkgs: stdenv.lib -> lib
Diffstat (limited to '5pkgs/uhub/default.nix')
-rw-r--r--5pkgs/uhub/default.nix6
1 files changed, 3 insertions, 3 deletions
diff --git a/5pkgs/uhub/default.nix b/5pkgs/uhub/default.nix
index 66dfebc3b..e0ee035e4 100644
--- a/5pkgs/uhub/default.nix
+++ b/5pkgs/uhub/default.nix
@@ -1,4 +1,4 @@
-{ stdenv, fetchpatch, fetchFromGitHub, cmake, openssl, sqlite, pkgconfig, systemd
+{ stdenv, lib, fetchpatch, fetchFromGitHub, cmake, openssl, sqlite, pkgconfig, systemd
, tlsSupport ? false }:
assert tlsSupport -> openssl != null;
@@ -15,7 +15,7 @@ stdenv.mkDerivation rec {
};
nativeBuildInputs = [ pkgconfig ];
- buildInputs = [ cmake sqlite systemd ] ++ stdenv.lib.optional tlsSupport openssl;
+ buildInputs = [ cmake sqlite systemd ] ++ lib.optional tlsSupport openssl;
outputs = [ "out"
"mod_example"
@@ -38,7 +38,7 @@ stdenv.mkDerivation rec {
${if tlsSupport then "-DSSL_SUPPORT=ON" else "-DSSL_SUPPORT=OFF"}
'';
- meta = with stdenv.lib; {
+ meta = with lib; {
description = "High performance peer-to-peer hub for the ADC network";
homepage = https://www.uhub.org/;
license = licenses.gpl3;