summaryrefslogtreecommitdiffstats
path: root/5pkgs/u3_tool
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2017-09-01 10:45:52 +0200
committermakefu <github@syntax-fehler.de>2017-09-01 10:45:52 +0200
commitf0036b91fd6ad6d9f1945bdfcbfa20e1db20d5d8 (patch)
treea00f407e81148a48dcf7d22e71aa60b7fbcc2b18 /5pkgs/u3_tool
parent8123df32833b9a7901ae67b71893c5ebbefb8bec (diff)
ma pkgs.u3_tool: init at 0.3
Diffstat (limited to '5pkgs/u3_tool')
-rw-r--r--5pkgs/u3_tool/default.nix22
1 files changed, 22 insertions, 0 deletions
diff --git a/5pkgs/u3_tool/default.nix b/5pkgs/u3_tool/default.nix
new file mode 100644
index 000000000..e8c5573a8
--- /dev/null
+++ b/5pkgs/u3_tool/default.nix
@@ -0,0 +1,22 @@
+{ stdenv, fetchurl }:
+
+stdenv.mkDerivation rec {
+ proj = "u3-tool";
+ name = "${proj}-${version}";
+ version = "0.3";
+
+ enableParallelBuilding = true;
+
+ src = fetchurl {
+ url = "mirror://sourceforge/${proj}/${name}.tar.gz";
+ sha256 = "1p9c9kibd1pdbdfa0nd0i3n7bvzi3xg0chm38jg3xfl8gsn0390f";
+ };
+
+ meta = {
+ description = "Tool for controlling the special features of a 'U3 smart drive' USB Flash disk.";
+ homepage = https://sourceforge.net/projects/u3-tool/ ;
+ license = stdenv.lib.licenses.gpl2;
+ platforms = stdenv.lib.platforms.linux;
+ maintainers = with stdenv.lib.maintainers; [ makefu ];
+ };
+}