summaryrefslogtreecommitdiffstats
path: root/5pkgs/custom/mediawiki-matrix-bot
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2021-09-01 13:35:05 +0200
committermakefu <github@syntax-fehler.de>2021-09-01 13:35:05 +0200
commit61285c93a9c37c91a11412838a828e5a0d73781d (patch)
tree0559e6fc9c444e884291cc521b674e0ae414e411 /5pkgs/custom/mediawiki-matrix-bot
parent8ed3a4c97fadb8403492ea24893e23f6c5ae52e5 (diff)
ma nix-community: add mediawiki-matrix-bot
Diffstat (limited to '5pkgs/custom/mediawiki-matrix-bot')
-rw-r--r--5pkgs/custom/mediawiki-matrix-bot/default.nix22
1 files changed, 22 insertions, 0 deletions
diff --git a/5pkgs/custom/mediawiki-matrix-bot/default.nix b/5pkgs/custom/mediawiki-matrix-bot/default.nix
new file mode 100644
index 000000000..4a91a9161
--- /dev/null
+++ b/5pkgs/custom/mediawiki-matrix-bot/default.nix
@@ -0,0 +1,22 @@
+{ buildPythonApplication, fetchFromGitHub, feedparser, matrix-nio, docopt, aiohttp, aiofiles,
+mypy }:
+
+buildPythonApplication rec {
+ pname = "mediawiki-matrix-bot";
+ version = "1.0.0";
+ src = fetchFromGitHub {
+ owner = "nix-community";
+ repo = "mediawiki-matrix-bot";
+ rev = "v${version}";
+ sha256 = "1923097j1xh34jmm0zhmvma614jcxaagj89c1fc1j2qyv14ybsvs";
+ };
+ propagatedBuildInputs = [
+ feedparser matrix-nio docopt aiohttp aiofiles
+ ];
+ nativeBuildInputs = [
+ mypy
+ ];
+ checkPhase = ''
+ mypy --strict mediawiki_matrix_bot
+ '';
+}