summaryrefslogtreecommitdiffstats
path: root/2configs/vpn/vpnws/client.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2017-12-18 21:27:26 +0100
committermakefu <github@syntax-fehler.de>2017-12-18 21:27:26 +0100
commite4d0ddc70be57937367dae618bb6033cdc6e8a04 (patch)
tree86be85f31270ab86cab5abad3ad697277c40bc82 /2configs/vpn/vpnws/client.nix
parente7403f23be3449c1bde59e6a4ccce17ef5e47423 (diff)
ma vpn: add vpnws client and server
Diffstat (limited to '2configs/vpn/vpnws/client.nix')
-rw-r--r--2configs/vpn/vpnws/client.nix9
1 files changed, 9 insertions, 0 deletions
diff --git a/2configs/vpn/vpnws/client.nix b/2configs/vpn/vpnws/client.nix
new file mode 100644
index 000000000..d06bc27db
--- /dev/null
+++ b/2configs/vpn/vpnws/client.nix
@@ -0,0 +1,9 @@
+{ pkgs, ... }:
+{
+ users.users.makefu.packages = with pkgs; [ iproute vpn-ws ];
+ # vpn-ws-client vpnws wss://localhost/vpn --no-verify --exec "ip link set vpnws up;ip addr add 10.244.1.2/24 dev vpnws"
+ networking.interfaces.vpnws = {
+ virtual = true;
+ virtualType = "tap";
+ };
+}