summaryrefslogtreecommitdiffstats
path: root/2configs/storj/client.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2021-03-12 20:09:10 +0100
committermakefu <github@syntax-fehler.de>2021-03-12 20:09:20 +0100
commit0a1ee1dac56462b5cc50dd28ae9319fe4746a120 (patch)
tree33e16782f622ee5a3afa0dafda6d8d47bb2bcef8 /2configs/storj/client.nix
parent0cee117f0f2f6de9a95d09b8f4f7f7982548768b (diff)
ma: deploy storj on omo, forward via gum
Diffstat (limited to '2configs/storj/client.nix')
-rw-r--r--2configs/storj/client.nix27
1 files changed, 27 insertions, 0 deletions
diff --git a/2configs/storj/client.nix b/2configs/storj/client.nix
new file mode 100644
index 000000000..e37e2ce23
--- /dev/null
+++ b/2configs/storj/client.nix
@@ -0,0 +1,27 @@
+{ lib, ... }:
+{
+ networking.firewall.allowedTCPPorts = [ 28967 ];
+ virtualisation.oci-containers.containers.storj-storagenode = {
+ image = "storjlabs/storagenode:latest";
+ ports = [
+ # TODO: omo ip
+ "0.0.0.0:28967:28967"
+ "127.0.0.1:14002:14002"
+ ];
+ environment = {
+ # SETUP = "true"; # must be run only once ...
+ WALLET = "0xeD0d2a2B33F6812b45d2D9FF7a139A3fF65a24C0";
+ EMAIL = "storj.io@syntax-fehler.de";
+ ADDRESS = "euer.krebsco.de:28967";
+ STORAGE = "3TB";
+ };
+ volumes = [
+ "/media/cryptX/lib/storj/identity:/app/identity"
+ "/media/cryptX/lib/storj/storage:/app/config"
+ ];
+ };
+ systemd.services.docker-storj-storagenode.serviceConfig = {
+ StandardOutput = lib.mkForce "journal";
+ StandardError = lib.mkForce "journal";
+ };
+}