summaryrefslogtreecommitdiffstats
path: root/2configs/share/gum-client.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2022-09-23 23:01:58 +0200
committermakefu <github@syntax-fehler.de>2022-09-23 23:01:58 +0200
commit2781b091a9de539222c12b7b4922a6aaba938754 (patch)
tree9a3ab9652ce8e517f6b50cec8d091c45a281a724 /2configs/share/gum-client.nix
parentaedad86dde73744161a6f6bdaead8bc59ff01917 (diff)
ma share: proxy hetzner via gum
Diffstat (limited to '2configs/share/gum-client.nix')
-rw-r--r--2configs/share/gum-client.nix23
1 files changed, 15 insertions, 8 deletions
diff --git a/2configs/share/gum-client.nix b/2configs/share/gum-client.nix
index db2adfb1c..5192ef515 100644
--- a/2configs/share/gum-client.nix
+++ b/2configs/share/gum-client.nix
@@ -2,21 +2,28 @@
let
automount_opts =
- [ "x-systemd.automount"
- "noauto" "x-systemd.idle-timeout=600"
- "x-systemd.device-timeout=5s"
- "x-systemd.mount-timeout=5s"
+ [ "x-systemd.automount" "noauto"
+ "x-systemd.idle-timeout=300"
+ "x-systemd.mount-timeout=60s"
];
- host = "nextgum"; #TODO
+ host = "gum"; #TODO
in {
- fileSystems."/media/download" = {
- device = "//${host}/download";
+ boot.extraModprobeConfig = ''
+ options cifs CIFSMaxBufSize=130048
+ '';
+ fileSystems."/media/cloud" = {
+ device = "//${host}/cloud-proxy";
fsType = "cifs";
options = automount_opts ++
[ "credentials=/var/src/secrets/download.smb"
"file_mode=0775"
"dir_mode=0775"
- "uid=9001"
+ "bsize=8388608"
+ "fsc"
+ "rsize=130048"
+ "cache=loose"
+ "uid=${toString config.users.users.download.uid}"
+ "gid=${toString config.users.groups.download.gid}"
"vers=3"
];
};