summaryrefslogtreecommitdiffstats
path: root/2configs/rtorrent.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2016-08-23 13:09:16 +0200
committermakefu <github@syntax-fehler.de>2016-08-23 13:09:16 +0200
commit75cad5f90a104cc715966ddb74ebaadefce722f6 (patch)
tree72069340c2a8dbcbff01e1fc809b6014ba63bf2a /2configs/rtorrent.nix
parent07eb26a7a7c968e43f69b2b2ba0f30ef9d81c37f (diff)
m rtorrent: split web rpc and rutorrent functionality
Diffstat (limited to '2configs/rtorrent.nix')
-rw-r--r--2configs/rtorrent.nix10
1 files changed, 8 insertions, 2 deletions
diff --git a/2configs/rtorrent.nix b/2configs/rtorrent.nix
index d024ded97..9e2990cab 100644
--- a/2configs/rtorrent.nix
+++ b/2configs/rtorrent.nix
@@ -2,11 +2,17 @@ _:
let
listenPort = 60123;
xml-port = 5000;
+ authfile = <torrent-secrets/authfile>;
in {
makefu.rtorrent = {
enable = true;
- web.enable = true;
- xmlrpc = "localhost:${toString xml-port}";
+ web = {
+ enable = true;
+ enableAuth = true;
+ inherit authfile;
+ };
+ rutorrent.enable = true;
+ enableXMLRPC = true;
logLevel = "debug";
inherit listenPort;
};