summaryrefslogtreecommitdiffstats
path: root/2configs/omo-share.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2016-02-01 22:01:41 +0100
committermakefu <github@syntax-fehler.de>2016-02-01 22:01:41 +0100
commitf1b96fc2292d7b3950b6fa62faa4f729d2522774 (patch)
tree48e93dea8cec234930c791eca9097df4670d368f /2configs/omo-share.nix
parent1925d1e2a602551f12e99ad57b2be3c0e46f0648 (diff)
ma 1 omo: add shares
Diffstat (limited to '2configs/omo-share.nix')
-rw-r--r--2configs/omo-share.nix68
1 files changed, 68 insertions, 0 deletions
diff --git a/2configs/omo-share.nix b/2configs/omo-share.nix
new file mode 100644
index 000000000..1e0975e1d
--- /dev/null
+++ b/2configs/omo-share.nix
@@ -0,0 +1,68 @@
+{ config, lib, pkgs, ... }:
+
+with lib;
+let
+ hostname = config.krebs.build.host.name;
+ # TODO local-ip from the nets config
+ local-ip = "192.168.1.11";
+ # local-ip = head config.krebs.build.host.nets.retiolum.addrs4;
+in {
+ krebs.nginx = {
+ enable = mkDefault true;
+ servers = {
+ omo-share = {
+ listen = [ "${local-ip}:80" ];
+ locations = singleton (nameValuePair "/" ''
+ autoindex on;
+ root /media;
+ limit_rate_after 100m;
+ limit_rate 5m;
+ mp4_buffer_size 4M;
+ mp4_max_buffer_size 10M;
+ allow all;
+ access_log off;
+ keepalive_timeout 65;
+ keepalive_requests 200;
+ reset_timedout_connection on;
+ sendfile on;
+ tcp_nopush on;
+ gzip off;
+ '');
+ };
+ };
+ };
+
+ # samba share /media/crypt1/share
+ users.users.smbguest = {
+ name = "smbguest";
+ uid = config.ids.uids.smbguest;
+ description = "smb guest user";
+ home = "/var/empty";
+ };
+ services.samba = {
+ enable = true;
+ shares = {
+ winshare = {
+ path = "/media/crypt1/share";
+ "read only" = "no";
+ browseable = "yes";
+ "guest ok" = "yes";
+ };
+ usenet = {
+ path = "/media/crypt0/usenet/dst";
+ "read only" = "yes";
+ browseable = "yes";
+ "guest ok" = "yes";
+ };
+ };
+ extraConfig = ''
+ guest account = smbguest
+ map to guest = bad user
+ # disable printing
+ load printers = no
+ printing = bsd
+ printcap name = /dev/null
+ disable spoolss = yes
+ '';
+ };
+}