summaryrefslogtreecommitdiffstats
path: root/2configs/logging/central-logging-server.nix
diff options
context:
space:
mode:
authorlassulus <lass@lassul.us>2017-02-05 23:10:23 +0100
committerlassulus <lass@lassul.us>2017-02-05 23:10:23 +0100
commit7ac4b20eaeb046d13c64399d7f9224279b9e69cb (patch)
tree857b4e45bfe4dc116b5e1f0d84288c93282435df /2configs/logging/central-logging-server.nix
parentb923e77aa9c32ced84f6135c62ae40b51b50952d (diff)
parent9d051137bf8051d19ba00336627223c49e19d4de (diff)
Merge remote-tracking branch 'prism/makefu'
Diffstat (limited to '2configs/logging/central-logging-server.nix')
-rw-r--r--2configs/logging/central-logging-server.nix23
1 files changed, 23 insertions, 0 deletions
diff --git a/2configs/logging/central-logging-server.nix b/2configs/logging/central-logging-server.nix
new file mode 100644
index 000000000..e2cfe6948
--- /dev/null
+++ b/2configs/logging/central-logging-server.nix
@@ -0,0 +1,23 @@
+{pkgs, config, ...}:
+
+with import <stockholm/lib>;
+let
+ es-port = 9200;
+ kibana-port = 5601;
+in {
+ services.elasticsearch = {
+ enable = true;
+ listenAddress = "0.0.0.0";
+ port = es-port;
+ };
+ services.kibana = {
+ enable = true;
+ listenAddress = "0.0.0.0";
+ port = kibana-port;
+ };
+
+ networking.firewall.extraCommands = ''
+ iptables -A INPUT -i retiolum -p tcp --dport ${toString es-port} -j ACCEPT
+ iptables -A INPUT -i retiolum -p tcp --dport ${toString es-port} -j ACCEPT
+ '';
+}