summaryrefslogtreecommitdiffstats
path: root/2configs/hw/tp-x220.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2015-09-02 10:02:05 +0200
committermakefu <github@syntax-fehler.de>2015-09-02 10:02:05 +0200
commit2d550c104cea85853c52545de979c74364824ab1 (patch)
treee73c68233ffc75d972a6b86952ff936c9868150a /2configs/hw/tp-x220.nix
parent4047e6557d19f0b3c15e5663e5d66d5ab981d306 (diff)
makefu: sort 2configs
Diffstat (limited to '2configs/hw/tp-x220.nix')
-rw-r--r--2configs/hw/tp-x220.nix25
1 files changed, 25 insertions, 0 deletions
diff --git a/2configs/hw/tp-x220.nix b/2configs/hw/tp-x220.nix
new file mode 100644
index 000000000..f03922150
--- /dev/null
+++ b/2configs/hw/tp-x220.nix
@@ -0,0 +1,25 @@
+{ config, lib, pkgs, ... }:
+
+with lib;
+{
+
+ imports = [ ./tp-x2x0.nix ];
+
+ boot.kernelModules = [ "kvm-intel" ];
+
+ services.xserver = {
+ videoDriver = "intel";
+ vaapiDrivers = [ pkgs.vaapiIntel pkgs.vaapiVdpau ];
+ deviceSection = ''
+ Option "AccelMethod" "sna"
+ '';
+ };
+
+ services.xserver.displayManager.sessionCommands =''
+ xinput set-int-prop "TPPS/2 IBM TrackPoint" "Evdev Wheel Emulation" 8 1
+ xinput set-int-prop "TPPS/2 IBM TrackPoint" "Evdev Wheel Emulation Button" 8 2
+ xinput set-prop "TPPS/2 IBM TrackPoint" "Evdev Wheel Emulation Axes" 6 7 4 5
+ # xinput set-int-prop "TPPS/2 IBM TrackPoint" "Evdev Wheel Emulation Timeout" 8 200
+ '';
+
+}