summaryrefslogtreecommitdiffstats
path: root/2configs/hw/bluetooth.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2018-09-17 00:41:36 +0200
committermakefu <github@syntax-fehler.de>2018-09-17 00:41:36 +0200
commit8d9055e6257f951ab7941a84942f30c80e41a1ee (patch)
tree5656e467e992ccc7f273b8ab4976191f4b96a34d /2configs/hw/bluetooth.nix
parent1dba99f317f4a8284a347b53dcd20a55a139f0ed (diff)
ma hw: disable on boot
Diffstat (limited to '2configs/hw/bluetooth.nix')
-rw-r--r--2configs/hw/bluetooth.nix13
1 files changed, 8 insertions, 5 deletions
diff --git a/2configs/hw/bluetooth.nix b/2configs/hw/bluetooth.nix
index 85c3190ff..313ca0147 100644
--- a/2configs/hw/bluetooth.nix
+++ b/2configs/hw/bluetooth.nix
@@ -29,11 +29,14 @@
# presumably a2dp Sink
# Enable profile:
## pacmd set-card-profile "$(pactl list cards short | egrep -o bluez_card[[:alnum:]._]+)" a2dp_sink
- hardware.bluetooth.extraConfig = '';
- [general]
- Enable=Source,Sink,Media,Socket
- '';
# connect via https://nixos.wiki/wiki/Bluetooth#Using_Bluetooth_headsets_with_PulseAudio
- hardware.bluetooth.enable = true;
+ hardware.bluetooth = {
+ enable = true;
+ powerOnBoot = false;
+ extraConfig = ''
+ [general]
+ Enable=Source,Sink,Media,Socket
+ '';
+ };
}