summaryrefslogtreecommitdiffstats
path: root/2configs/home/ham/automation/pflanzen_giessen_erinnerung.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2021-05-15 13:13:13 +0200
committermakefu <github@syntax-fehler.de>2021-05-15 13:16:52 +0200
commitcd44d3ff2bba75a1ec6946ea4197b75b64b0be39 (patch)
tree5d64356f64a8dde2f85b33b72e9c58909bc9750d /2configs/home/ham/automation/pflanzen_giessen_erinnerung.nix
parentd3b6472d0450fc9e10d8ac8676bf2a99d5d39439 (diff)
ma home/ham: add signal-rest, update automations
Diffstat (limited to '2configs/home/ham/automation/pflanzen_giessen_erinnerung.nix')
-rw-r--r--2configs/home/ham/automation/pflanzen_giessen_erinnerung.nix39
1 files changed, 39 insertions, 0 deletions
diff --git a/2configs/home/ham/automation/pflanzen_giessen_erinnerung.nix b/2configs/home/ham/automation/pflanzen_giessen_erinnerung.nix
new file mode 100644
index 000000000..3aaa57bd6
--- /dev/null
+++ b/2configs/home/ham/automation/pflanzen_giessen_erinnerung.nix
@@ -0,0 +1,39 @@
+let
+ notify_felix = message: {
+ service = "notify.signal_felix";
+ data.message = message;
+ };
+ notify_home = message: {
+ service = "notify.signal_home";
+ data.message = message;
+ };
+in
+{
+ services.home-assistant.config.automation =
+ [
+ {
+ alias = "Pflanzen Giessen Erinnerung Daily";
+ trigger = {
+ platform = "time";
+ at = "12:15:00";
+ };
+ action = [
+ (notify_felix "Es ist Mittagszeit und du kannst ruhig einmal alle Blumen im Zimmer giessen")
+ ];
+ }
+ {
+ alias = "Pflanzen Giessen Erinnerung Weekly";
+ trigger = {
+ platform = "time";
+ at = "12:15:00";
+ };
+ condition = {
+ condition = "time";
+ weekday = [ "sat" ];
+ };
+ action = [
+ (notify_home "Es ist Wochenende und die Pflanzen würden sich über ein bisschen Wasser freuen.")
+ ];
+ }
+ ];
+}
[cgit] Unable to lock slot /tmp/cgit/64200000.lock: No such file or directory (2)