summaryrefslogtreecommitdiffstats
path: root/2configs/gum-share.nix
diff options
context:
space:
mode:
authortv <tv@krebsco.de>2016-11-11 08:49:37 +0100
committertv <tv@krebsco.de>2016-11-11 08:49:37 +0100
commit508da1841b90c4da2b179d1f2208079b8e634fcd (patch)
tree458acdb0a728fc56055b3efca5d41a8478a08746 /2configs/gum-share.nix
parent49dd6aebd1bd075e85d4796e2b0f5321c60a4d9e (diff)
parentc05b8eb332e5a1a269beb548e11f047f3a00a349 (diff)
Merge remote-tracking branch 'prism/master'
Diffstat (limited to '2configs/gum-share.nix')
-rw-r--r--2configs/gum-share.nix39
1 files changed, 39 insertions, 0 deletions
diff --git a/2configs/gum-share.nix b/2configs/gum-share.nix
new file mode 100644
index 000000000..e578f43d3
--- /dev/null
+++ b/2configs/gum-share.nix
@@ -0,0 +1,39 @@
+{ config, lib, pkgs, ... }:
+
+with config.krebs.lib;
+let
+ hostname = config.krebs.build.host.name;
+in {
+ # users.users.smbguest = {
+ # name = "smbguest";
+ # uid = config.ids.uids.smbguest;
+ # description = "smb guest user";
+ # home = "/var/empty";
+ # };
+
+ users.users.download = { };
+ services.samba = {
+ enable = true;
+ shares = {
+ download = {
+ path = "/var/download";
+ "read only" = "no";
+ browseable = "yes";
+ "guest ok" = "no";
+ "valid users" = "download";
+ };
+ };
+ extraConfig = ''
+ # guest account = smbguest
+ # map to guest = bad user
+ # disable printing
+ load printers = no
+ printing = bsd
+ printcap name = /dev/null
+ disable spoolss = yes
+ '';
+ };
+ networking.firewall.extraCommands = ''
+ iptables -A INPUT -i retiolum -p tcp --dport 445 -j ACCEPT
+ '';
+}
[cgit] Unable to lock slot /tmp/cgit/56000000.lock: No such file or directory (2)