summaryrefslogtreecommitdiffstats
path: root/2configs/fetchWallpaper.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2015-12-13 13:52:15 +0100
committermakefu <github@syntax-fehler.de>2015-12-13 13:52:15 +0100
commit59dc20ba56fd5444dc37eaeb1f870e511af7936f (patch)
tree7a58e11a7fac38409bebcf7be932e1f0cbe5e246 /2configs/fetchWallpaper.nix
parentaadc479bb6e8d4792a41920ac5751c29c93115bc (diff)
m 2 fetchWallpaper: default enabled for mainlaptop
Diffstat (limited to '2configs/fetchWallpaper.nix')
-rw-r--r--2configs/fetchWallpaper.nix24
1 files changed, 24 insertions, 0 deletions
diff --git a/2configs/fetchWallpaper.nix b/2configs/fetchWallpaper.nix
new file mode 100644
index 000000000..b071a128d
--- /dev/null
+++ b/2configs/fetchWallpaper.nix
@@ -0,0 +1,24 @@
+{ config, pkgs, ... }:
+
+let
+ # check if laptop runs on umts
+ weaksauce-internet = with pkgs;writeScript "weaksauce-internet" ''
+ #! /bin/sh
+ if ${iproute}/bin/ip addr show dev ppp0 2>/dev/null \
+ | ${gnugrep}/bin/grep -q inet;then
+ exit 1
+ fi
+ '';
+
+in {
+ krebs.fetchWallpaper = {
+ enable = true;
+ display = ":0";
+ predicate = weaksauce-internet;
+ timerConfig = {
+ OnCalendar = "*:0/30";
+ };
+ url = "http://echelon/wallpaper.png";
+ };
+}
+