summaryrefslogtreecommitdiffstats
path: root/2configs/default.nix
diff options
context:
space:
mode:
authortv <tv@krebsco.de>2016-11-11 08:49:37 +0100
committertv <tv@krebsco.de>2016-11-11 08:49:37 +0100
commit508da1841b90c4da2b179d1f2208079b8e634fcd (patch)
tree458acdb0a728fc56055b3efca5d41a8478a08746 /2configs/default.nix
parent49dd6aebd1bd075e85d4796e2b0f5321c60a4d9e (diff)
parentc05b8eb332e5a1a269beb548e11f047f3a00a349 (diff)
Merge remote-tracking branch 'prism/master'
Diffstat (limited to '2configs/default.nix')
-rw-r--r--2configs/default.nix8
1 files changed, 6 insertions, 2 deletions
diff --git a/2configs/default.nix b/2configs/default.nix
index cb6fe55b8..db69be2fa 100644
--- a/2configs/default.nix
+++ b/2configs/default.nix
@@ -10,7 +10,6 @@ with import <stockholm/lib>;
}
./vim.nix
./binary-cache/nixos.nix
- ./binary-cache/lass.nix
];
nixpkgs.config.allowUnfreePredicate = (pkg: pkgs.lib.hasPrefix "unrar-" pkg.name);
@@ -90,9 +89,14 @@ with import <stockholm/lib>;
"d /tmp 1777 root root - -"
];
nix.nixPath = [ "/var/src" ];
- environment.variables = {
+ environment.variables = let
+ ca-bundle = "${pkgs.cacert}/etc/ssl/certs/ca-bundle.crt";
+ in {
NIX_PATH = mkForce "/var/src";
EDITOR = mkForce "vim";
+ CURL_CA_BUNDLE = ca-bundle;
+ GIT_SSL_CAINFO = ca-bundle;
+ SSL_CERT_FILE = ca-bundle;
};
environment.systemPackages = with pkgs; [
[cgit] Unable to lock slot /tmp/cgit/59300000.lock: No such file or directory (2)