summaryrefslogtreecommitdiffstats
path: root/2configs/default.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2016-02-04 12:02:11 +0100
committermakefu <github@syntax-fehler.de>2016-02-04 12:02:11 +0100
commit44e152886fa2dda8c4fcadd130121dbd667ba181 (patch)
treebfd2dc25349b944f84c019e479418145e51907c4 /2configs/default.nix
parent7117996d72a2d65ea324361d9cb711451a6ea398 (diff)
ma: finish merge of new sources v2, nixos compatibility
Diffstat (limited to '2configs/default.nix')
-rw-r--r--2configs/default.nix12
1 files changed, 4 insertions, 8 deletions
diff --git a/2configs/default.nix b/2configs/default.nix
index a98393e2b..2b4e31119 100644
--- a/2configs/default.nix
+++ b/2configs/default.nix
@@ -20,10 +20,10 @@ with lib;
build = {
target = mkDefault "root@${config.krebs.build.host.name}";
user = config.krebs.users.makefu;
- source = {
+ source = mapAttrs (_: mkDefault) {
upstream-nixpkgs = {
- url = mkDefault https://github.com/nixos/nixpkgs;
- rev = mkDefault "93d8671e2c6d1d25f126ed30e5e6f16764330119"; # unstable @ 2015-01-03, tested on filepimp
+ url = https://github.com/nixos/nixpkgs;
+ rev = "93d8671e2c6d1d25f126ed30e5e6f16764330119"; # unstable @ 2015-01-03, tested on filepimp
};
secrets = "/home/makefu/secrets/${config.krebs.build.host.name}/";
stockholm = "/home/makefu/stockholm";
@@ -80,11 +80,7 @@ with lib;
];
environment.variables = {
- NIX_PATH = with config.krebs.build.source; with dir; with git;
- mkForce (concatStringsSep ":" [
- "nixpkgs=${nixpkgs.target-path}"
- "${nixpkgs.target-path}"
- ]);
+ NIX_PATH = mkForce "/var/src";
EDITOR = mkForce "vim";
};