summaryrefslogtreecommitdiffstats
path: root/2configs/bureautomation/switch/tasmota_switch.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2020-11-18 20:50:43 +0100
committermakefu <github@syntax-fehler.de>2020-11-18 20:51:14 +0100
commit34b220961fffac0629c66a876d169e58ded9a0df (patch)
tree8e765d96c9d02c1a01d15db5ce48d63f253d4e39 /2configs/bureautomation/switch/tasmota_switch.nix
parent265149d4a3d5991d03d3fb4e22e0aed70469b54d (diff)
ma bureautomation: move to 20.09 style imports
Diffstat (limited to '2configs/bureautomation/switch/tasmota_switch.nix')
-rw-r--r--2configs/bureautomation/switch/tasmota_switch.nix17
1 files changed, 10 insertions, 7 deletions
diff --git a/2configs/bureautomation/switch/tasmota_switch.nix b/2configs/bureautomation/switch/tasmota_switch.nix
index 115bae0cc..6c5f6b8a6 100644
--- a/2configs/bureautomation/switch/tasmota_switch.nix
+++ b/2configs/bureautomation/switch/tasmota_switch.nix
@@ -13,10 +13,13 @@ let
retain = false;
qos = 1;
};
-in [
- (tasmota_plug "Bauarbeiterlampe" "plug")
- (tasmota_plug "Blitzdings" "plug2")
- (tasmota_plug "Fernseher" "plug3")
- (tasmota_plug "Feuer" "plug4")
- (tasmota_plug "Blaulicht" "plug5")
-]
+in {
+ services.home-assistant.config.switch =
+ [
+ (tasmota_plug "Bauarbeiterlampe" "plug")
+ (tasmota_plug "Blitzdings" "plug2")
+ (tasmota_plug "Fernseher" "plug3")
+ (tasmota_plug "Feuer" "plug4")
+ (tasmota_plug "Blaulicht" "plug5")
+ ];
+}