summaryrefslogtreecommitdiffstats
path: root/2configs/bureautomation/led-fader.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2019-03-06 16:42:27 +0100
committermakefu <github@syntax-fehler.de>2019-03-06 16:42:27 +0100
commitc81db9c8cea9e85aa9f2e840d39502fc7222ed90 (patch)
treeb752f082072945c22abb9232fb4664c4ff32a9f7 /2configs/bureautomation/led-fader.nix
parente1b003a1123ab261b5448e9183b00c5f953faa90 (diff)
ma bureautomation: split into files
Diffstat (limited to '2configs/bureautomation/led-fader.nix')
-rw-r--r--2configs/bureautomation/led-fader.nix23
1 files changed, 23 insertions, 0 deletions
diff --git a/2configs/bureautomation/led-fader.nix b/2configs/bureautomation/led-fader.nix
new file mode 100644
index 000000000..d7f728534
--- /dev/null
+++ b/2configs/bureautomation/led-fader.nix
@@ -0,0 +1,23 @@
+{ config, lib, pkgs, buildPythonPackage, ... }:
+
+let
+ mq = "192.168.8.11";
+ pkg = pkgs.ampel;
+in {
+ systemd.services.led-fader = {
+ description = "Send led change to message queue";
+ environment = {
+ NIX_PATH = "/var/src";
+ };
+ after = [ "network-online.target" ] ++ (lib.optional config.services.mosquitto.enable "mosquitto.service");
+ wantedBy = [ "multi-user.target" ];
+ serviceConfig = {
+ # User = "nobody"; # need a user with permissions to run nix-shell
+ ExecStartPre = pkgs.writeDash "sleep.sh" "sleep 2";
+ ExecStart = "${pkg}/bin/ampel";
+ Restart = "always";
+ RestartSec = 10;
+ PrivateTmp = true;
+ };
+ };
+}