summaryrefslogtreecommitdiffstats
path: root/2configs/bureautomation/dwd_pollen.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2019-06-17 07:54:31 +0200
committermakefu <github@syntax-fehler.de>2019-06-17 07:54:31 +0200
commit2845a2da8305ff1c8bfd1d2ee1e8e6e41b121ed3 (patch)
tree2fbd121a4295b0e1ea8ed35aec632a32d09dc074 /2configs/bureautomation/dwd_pollen.nix
parent310170ce7034ea84c6e416c23e0c1e8ef6864074 (diff)
ma bureautomation: prepare dwd_pollen, update presence
Diffstat (limited to '2configs/bureautomation/dwd_pollen.nix')
-rw-r--r--2configs/bureautomation/dwd_pollen.nix32
1 files changed, 32 insertions, 0 deletions
diff --git a/2configs/bureautomation/dwd_pollen.nix b/2configs/bureautomation/dwd_pollen.nix
new file mode 100644
index 000000000..39d9c3069
--- /dev/null
+++ b/2configs/bureautomation/dwd_pollen.nix
@@ -0,0 +1,32 @@
+{ lib
+, buildPythonPackage
+, fetchFromGitHub
+, python
+, voluptuous
+}:
+
+buildPythonPackage rec {
+ format = "other";
+ pname = "dwd_pollen";
+ version = "0.1";
+
+ src = fetchFromGitHub {
+ owner = "marcschumacher";
+ repo = "dwd_pollen";
+ rev = version;
+ sha256 = "1af2mx99gv2hk1ad53g21fwkdfdbymqcdl3jvzd1yg7dgxlkhbj1";
+ };
+ propagatedBuildInputs = [
+ voluptuous
+ ];
+ installPhase = ''
+ install -D -t $out/${python.sitePackages}/homeassistant/components/sensor/dwd_pollen *
+ '';
+
+ meta = with lib; {
+ description = "Home Assistant component to retrieve Pollen data from DWD (Germany)";
+ homepage = https://github.com/marcschumacher/dwd_pollen;
+ license = licenses.mit;
+ maintainers = [ maintainers.makefu ];
+ };
+}