summaryrefslogtreecommitdiffstats
path: root/2configs/bureautomation/binary_sensor/buttons.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2020-11-18 20:50:43 +0100
committermakefu <github@syntax-fehler.de>2020-11-18 20:51:14 +0100
commit34b220961fffac0629c66a876d169e58ded9a0df (patch)
tree8e765d96c9d02c1a01d15db5ce48d63f253d4e39 /2configs/bureautomation/binary_sensor/buttons.nix
parent265149d4a3d5991d03d3fb4e22e0aed70469b54d (diff)
ma bureautomation: move to 20.09 style imports
Diffstat (limited to '2configs/bureautomation/binary_sensor/buttons.nix')
-rw-r--r--2configs/bureautomation/binary_sensor/buttons.nix9
1 files changed, 6 insertions, 3 deletions
diff --git a/2configs/bureautomation/binary_sensor/buttons.nix b/2configs/bureautomation/binary_sensor/buttons.nix
index e23c4a362..20590a6b3 100644
--- a/2configs/bureautomation/binary_sensor/buttons.nix
+++ b/2configs/bureautomation/binary_sensor/buttons.nix
@@ -12,6 +12,9 @@ let
# expire_after = "5"; #expire after 5 seconds
qos = 1;
};
-in [
- (tasmota_button "RedButton" "redbutton")
-]
+in {
+ services.home-assistant.config.binary_sensor =
+ [
+ (tasmota_button "RedButton" "redbutton")
+ ];
+}