summaryrefslogtreecommitdiffstats
path: root/1systems/x/x13/disk.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2023-06-14 23:37:38 +0200
committermakefu <github@syntax-fehler.de>2023-06-14 23:38:41 +0200
commita2040ce915a4e8a2ae9f0897a13f77d6592dd81e (patch)
treebda6ff26e479e638410d421d5edf3b3dcc3de1bb /1systems/x/x13/disk.nix
parentb9a5d97bf892bd046afb670e4d362b0e1386f184 (diff)
fs: single-disk-encrypted-zfs takes hostId as parameter
Diffstat (limited to '1systems/x/x13/disk.nix')
-rw-r--r--1systems/x/x13/disk.nix70
1 files changed, 0 insertions, 70 deletions
diff --git a/1systems/x/x13/disk.nix b/1systems/x/x13/disk.nix
deleted file mode 100644
index 3fae8d410..000000000
--- a/1systems/x/x13/disk.nix
+++ /dev/null
@@ -1,70 +0,0 @@
-{ ... }:
-let
- disk = "/dev/nvme0n1";
-in {
- disko.devices = {
- disk = {
- nvme = {
- type = "disk";
- device = disk;
- content = {
- type = "table";
- format = "gpt";
- partitions = [
- {
- name = "ESP";
- start = "0";
- end = "512MiB";
- fs-type = "fat32";
- bootable = true;
- content = {
- type = "filesystem";
- format = "vfat";
- mountpoint = "/boot";
- };
- }
- {
- name = "zfs";
- start = "512MiB";
- end = "100%";
- content = {
- type = "zfs";
- pool = "tank";
- };
- }
- ];
- };
- };
- };
- zpool = {
- tank = {
- type = "zpool";
- rootFsOptions = {
- compression = "lz4";
- #reservation = "5G";
- "com.sun:auto-snapshot" = "false";
- };
- mountpoint = null;
- postCreateHook = "zfs snapshot tank@blank";
-
- datasets = {
-
- root = {
- type = "zfs_fs";
- mountpoint = "/";
- options = {
- encryption = "aes-256-gcm";
- keyformat = "passphrase";
- "com.sun:auto-snapshot" = "true";
- };
- #keylocation = "file:///tmp/secret.key";
- };
- "root/home" = {
- type = "zfs_fs";
- mountpoint = "/home";
- };
- };
- };
- };
- };
-}