summaryrefslogtreecommitdiffstats
path: root/1systems/wry.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2015-10-19 19:48:56 +0200
committermakefu <github@syntax-fehler.de>2015-10-19 19:48:56 +0200
commit7a1dfc7697051456c3e845798cb15a76ed88338f (patch)
treeb6d29b08584df1a9f46296b5f556bbb08dd2d3ef /1systems/wry.nix
parent43cf1495f5fb634527b2726d4c154e90f90ccee1 (diff)
m 1 wry: start Reaktor
Diffstat (limited to '1systems/wry.nix')
-rw-r--r--1systems/wry.nix32
1 files changed, 19 insertions, 13 deletions
diff --git a/1systems/wry.nix b/1systems/wry.nix
index 819a208ac..d8c8d6fa1 100644
--- a/1systems/wry.nix
+++ b/1systems/wry.nix
@@ -5,23 +5,29 @@ let
ip = (lib.head config.krebs.build.host.nets.internet.addrs4);
in {
imports = [
- ../../tv/2configs/CAC-CentOS-7-64bit.nix
- ../2configs/base.nix
- ../2configs/base-sources.nix
- ../2configs/tinc-basic-retiolum.nix
+ # TODO: copy this config or move to krebs
+ ../../tv/2configs/CAC-CentOS-7-64bit.nix
+ ../2configs/base.nix
+ ../2configs/base-sources.nix
+ ../2configs/tinc-basic-retiolum.nix
+
+ # Reaktor
+ ../2configs/Reaktor/simpleExtend.nix
];
+ krebs.Reaktor.enable = true;
+
networking.firewall.allowPing = true;
networking.interfaces.enp2s1.ip4 = [
- {
- address = ip;
- prefixLength = 24;
- }
- ];
- networking.defaultGateway = "104.233.87.1";
- networking.nameservers = [
- "8.8.8.8"
- ];
+ {
+ address = ip;
+ prefixLength = 24;
+ }
+ ];
+ networking.defaultGateway = "104.233.87.1";
+ networking.nameservers = [
+ "8.8.8.8"
+ ];
# based on ../../tv/2configs/CAC-Developer-2.nix
sound.enable = false;