summaryrefslogtreecommitdiffstats
path: root/1systems/omo/hw/tsp-tools.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2018-09-13 16:17:39 +0200
committermakefu <github@syntax-fehler.de>2018-09-13 16:17:39 +0200
commit36e021165b94d925d1d481147a0cb046b7774185 (patch)
tree219ffd55f999da1cec99fca1365c6ad62adfb4c5 /1systems/omo/hw/tsp-tools.nix
parenteedb1ce622987b24090c916405a19caaf4debd65 (diff)
ma omo.r: split hardware config, use disko for tsp hardware
Diffstat (limited to '1systems/omo/hw/tsp-tools.nix')
-rw-r--r--1systems/omo/hw/tsp-tools.nix11
1 files changed, 11 insertions, 0 deletions
diff --git a/1systems/omo/hw/tsp-tools.nix b/1systems/omo/hw/tsp-tools.nix
new file mode 100644
index 000000000..6579edd9d
--- /dev/null
+++ b/1systems/omo/hw/tsp-tools.nix
@@ -0,0 +1,11 @@
+let
+ disko = import (builtins.fetchGit {
+ url = https://cgit.lassul.us/disko/;
+ rev = "9c9b62e15e4ac11d4379e66b974f1389daf939fe";
+ });
+
+ cfg = builtins.fromJSON (builtins.readFile ../../hardware/tsp-disk.json);
+in ''
+${disko.create cfg}
+${disko.mount cfg}
+''