summaryrefslogtreecommitdiffstats
path: root/1systems/omo.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2015-12-16 12:06:44 +0100
committermakefu <github@syntax-fehler.de>2015-12-16 12:06:44 +0100
commitdd8fa5b486100c0d0b46bdebddc1f5626883bb01 (patch)
treee4eda37c4ed07617a45fefa66c8b1859e7ab15f9 /1systems/omo.nix
parent3edf40dc0e4bb42225768156a93be0a61d5fc159 (diff)
m 1 omo: init
Diffstat (limited to '1systems/omo.nix')
-rw-r--r--1systems/omo.nix37
1 files changed, 37 insertions, 0 deletions
diff --git a/1systems/omo.nix b/1systems/omo.nix
new file mode 100644
index 000000000..6ae79398a
--- /dev/null
+++ b/1systems/omo.nix
@@ -0,0 +1,37 @@
+# Edit this configuration file to define what should be installed on
+# your system. Help is available in the configuration.nix(5) man page
+# and in the NixOS manual (accessible by running ‘nixos-help’).
+
+{ config, pkgs, ... }:
+
+{
+ imports =
+ [ # Include the results of the hardware scan.
+ ../2configs/fs/single-partition-ext4.nix
+ ../2configs/tinc-basic-retiolum.nix
+ ../2configs/exim-retiolum.nix
+ ];
+ krebs.build.host = config.krebs.hosts.omo;
+
+ # AMD E350
+ boot = {
+ loader.grub.device = "/dev/sda";
+
+ initrd.availableKernelModules = [
+ "usb_storage"
+ "ahci"
+ "xhci_hcd"
+ "ata_piix"
+ "uhci_hcd"
+ "ehci_pci"
+ ];
+
+ kernelModules = [ ];
+ extraModulePackages = [ ];
+ };
+
+ hardware.enableAllFirmware = true;
+ hardware.cpu.amd.updateMicrocode = true;
+
+ networking.firewall.allowPing = true;
+}