summaryrefslogtreecommitdiffstats
path: root/1systems/nextgum/hardware-config.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2018-08-06 16:32:32 +0200
committermakefu <github@syntax-fehler.de>2018-08-06 16:32:32 +0200
commit2cc52d5a249b57a9e39dc55ab4053ff85e81f8bc (patch)
treed9ea3e27981aa927a64e957987e0edf004912a59 /1systems/nextgum/hardware-config.nix
parent2af234e1d21f9c2e3b1cb2ae5454b399dac94314 (diff)
ma nextgum/hardware-config: add new logical devices
Diffstat (limited to '1systems/nextgum/hardware-config.nix')
-rw-r--r--1systems/nextgum/hardware-config.nix14
1 files changed, 12 insertions, 2 deletions
diff --git a/1systems/nextgum/hardware-config.nix b/1systems/nextgum/hardware-config.nix
index 36fea6544..944210701 100644
--- a/1systems/nextgum/hardware-config.nix
+++ b/1systems/nextgum/hardware-config.nix
@@ -45,12 +45,20 @@ in {
"ata_piix" "vmw_pvscsi" "virtio_pci" "sd_mod" "ahci"
"xhci_pci" "ehci_pci" "ahci" "sd_mod"
];
- boot.kernelModules = [ "kvm-intel" ];
+ boot.kernelModules = [ "kvm-intel" "dm-raid" "dm_thin_pool" ];
hardware.enableRedistributableFirmware = true;
fileSystems."/" = {
device = "/dev/mapper/nixos-root";
fsType = "ext4";
};
+ fileSystems."/var/lib" = {
+ device = "/dev/mapper/nixos-lib";
+ fsType = "ext4";
+ };
+ fileSystems."/var/download" = {
+ device = "/dev/mapper/nixos-download";
+ fsType = "ext4";
+ };
fileSystems."/boot" = {
device = "/dev/sda2";
fsType = "vfat";
@@ -69,7 +77,9 @@ in {
#pvcreate /dev/sda3
#pvcreate /dev/sdb1
#vgcreate nixos /dev/sda3 /dev/sdb1
- #lvcreate -L 120G -n root nixos
+ #lvcreate -L 120G -m 1 -n root nixos
+ #lvcreate -L 50G -m 1 -n lib nixos
+ #lvcreate -L 50G -n download nixos
#mkfs.ext4 /dev/mapper/nixos-root
#mount /dev/mapper/nixos-root /mnt
#mkdir /mnt/boot