summaryrefslogtreecommitdiffstats
path: root/1systems/fileleech.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2016-12-22 14:12:24 +0100
committermakefu <github@syntax-fehler.de>2016-12-22 14:15:17 +0100
commit3756ac532cdeea2300d658254a0c7a556c1a0e1c (patch)
treec335bb2c57ac24aa6fa397a719139c0df08c41bd /1systems/fileleech.nix
parent140cd53473519cffd5daf7ae22576ef91574fc14 (diff)
m 3 server-config: init
Diffstat (limited to '1systems/fileleech.nix')
-rw-r--r--1systems/fileleech.nix27
1 files changed, 27 insertions, 0 deletions
diff --git a/1systems/fileleech.nix b/1systems/fileleech.nix
new file mode 100644
index 000000000..4d9b37cea
--- /dev/null
+++ b/1systems/fileleech.nix
@@ -0,0 +1,27 @@
+{ config, pkgs, ... }:
+{
+ imports = [
+ ../.
+ # configure your hw:
+ # ../2configs/hw/CAC.nix
+ # ../2configs/fs/CAC-CentOS-7-64bit.nix
+ ../2configs/save-diskspace.nix
+ ../2configs/tinc/retiolum.nix
+
+ ];
+ krebs = {
+ enable = true;
+ build.host = config.krebs.hosts.fileleech;
+ };
+
+ boot.loader.grub.enable = true;
+ boot.loader.grub.version = 2;
+ boot.loader.grub.device = "/dev/disk/by-id/ata-INTEL_SSDSA2M080G2GC_CVPO003402PB080BGN";
+ fileSystems."/" = {
+ device = "/dev/disk/by-id/ata-INTEL_SSDSA2M080G2GC_CVPO003402PB080BGN";
+ };
+
+ boot.initrd.availableKernelModules = [ "uhci_hcd" "ehci_pci" "ahci" "aacraid" "usb_storage" "usbhid" ];
+ boot.kernelModules = [ "kvm-intel" ];
+ boot.extraModulePackages = [ ];
+}