summaryrefslogtreecommitdiffstats
path: root/1systems/cake/hardware-config.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2019-01-13 23:05:12 +0100
committermakefu <github@syntax-fehler.de>2019-01-13 23:05:12 +0100
commit43bfbd939a6e962aa9e65c18c69104a87f0bd477 (patch)
treebf48d4d6fa2d043c86eb79c0e93a5442dd670a33 /1systems/cake/hardware-config.nix
parent6d04946f8ce52bfe23277f649f19b0692b1fee15 (diff)
ma cake.r: remove hack to get wifi working
Diffstat (limited to '1systems/cake/hardware-config.nix')
-rw-r--r--1systems/cake/hardware-config.nix26
1 files changed, 26 insertions, 0 deletions
diff --git a/1systems/cake/hardware-config.nix b/1systems/cake/hardware-config.nix
new file mode 100644
index 000000000..a81dce4f9
--- /dev/null
+++ b/1systems/cake/hardware-config.nix
@@ -0,0 +1,26 @@
+{ pkgs, lib, ... }:
+{
+ # raspi3
+ boot.loader.grub.enable = false;
+ boot.loader.generic-extlinux-compatible.enable = true;
+ boot.kernelParams = ["cma=32M" "console=ttyS0,115200n8" "console=tty0" ];
+ boot.tmpOnTmpfs = lib.mkForce false;
+ hardware.enableRedistributableFirmware = true;
+
+ ## wifi not working, will be fixed with https://github.com/NixOS/nixpkgs/pull/53747
+ # boot.kernelPackages = pkgs.linuxPackages_latest;
+ boot.kernelPackages = pkgs.linuxPackages;
+
+ networking.wireless.enable = true;
+ # File systems configuration for using the installer's partition layout
+ fileSystems = {
+ "/boot" = {
+ device = "/dev/disk/by-label/NIXOS_BOOT";
+ fsType = "vfat";
+ };
+ "/" = {
+ device = "/dev/disk/by-label/NIXOS_SD";
+ fsType = "ext4";
+ };
+ };
+}