summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2017-12-06 13:52:53 +0100
committermakefu <github@syntax-fehler.de>2017-12-06 13:52:53 +0100
commit6bfcd8a348962f0357372f4e74c286f93e6eec26 (patch)
tree00d97bfb8a716afc118a35f7bb7097456bf46511 /setup.py
parent8727451b41b057d36e76cecdb543015c0f50b304 (diff)
setup.py: init
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py33
1 files changed, 33 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 0000000..cfbb372
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,33 @@
+from setuptools import setup
+
+import sys
+
+setup(
+ name='ampel',
+ version='0.2.3',
+
+ description='uses the ampel',
+ long_description=open("README.md").read(),
+ license='WTFPL',
+ url='http://localhost/',
+ download_url='http://localhost/',
+
+ author='makefu',
+ author_email='github.com@syntax-fehler.de',
+
+ packages=['ampel'],
+ entry_points={
+ 'console_scripts' : [ 'ampel = ampel.ampel:main' ],
+ },
+ install_requires= [
+ 'requests','docopt','influxdb', 'paho-mqtt','pytz'
+ ],
+ classifiers=[
+ "Natural Language :: English",
+ "Operating System :: POSIX :: Linux",
+ "Programming Language :: Python",
+ "Programming Language :: Python :: 3",
+ "Programming Language :: Python :: Implementation :: CPython",
+ ],
+)
+